Being blunt seems to have worked

I’ve been having problems keeping my blogs online, or at the very least active and available for the past few weeks.  The web hosting service that I use is called Servage One (though when I started using them it was just called ‘Servage’) and its located in Germany.  For the past 13 years, I’ve owned several domains, and have kept them hosted here because the price was right, it was convenient, they had a good reputation for being friendly with ‘adult’ leaning websites and they offered a good deal more than their competitors.  Too, if you brought them business, they would give you a free month of hosting for every customer that used a link you were given, so you could, in theory pay for your entire hosting based on how many customers you brought to them.  (Basically pay for a year and get a year free if you had 12 friends using their service) [Yes, I was mansplaining.  Get over it.]

In those years, my yearly bill has not gone up or down and I’ve been satisfied with the service I’ve received.  On occasion there would be a blip, but for the most part service was exemplary.  In 2006 when I first signed up, they offered unlimited bandwidth, unlimited hosted domains, unlimited emails, and 750 GBs of storage.  A few years down the road, they upped the storage to unlimited, along with all of the other amenities and then tacked on a free domain, which you would register through them and host there.  Without much warning a couple of years ago (actually zero warning) they dropped the unlimited storage option, scaling it back to the original 750 gigs.  I’m guessing this was because none of their customers were actually using that much space, and it made sense to cut it back, thereby freeing up more space on their servers for more customers.  A couple of months ago, right around the upgrade, they downgraded the available space to 200 gigs.  That was a pretty big downgrade, imo.  But, at least they didn’t up the price at the same time.  That would have been a deal-breaker, I think.

As I’ve mentioned in another post this service decided last year that they were going to upgrade their systems and do a large and laborious migration to a new storage facility as well as create a whole new hosting and support platform.  Not something cookie cutter like cPanel, something made in-house.  Have to give props when someone wants to design their own system from the ground up.  As many headaches that arise, even unexpected ones like they started to experience about 2 months ago where nearly the entire site went down for a period of 14 hours.  And stayed down.  To their credit, they kept everyone in the loop about what was going on, since email too was unavailable.   So long as you knew to check the hosting platform for updates.   Nevertheless, the outage was fixed for the most part, my domains were loading ok, but the blogs strangely enough weren’t.

At first, I was patient.  I figured there were going to be hiccups and I wanted to be a good customer, not making waves and allowing them to get the problems fixed.  However, that didn’t seem to be working very well, since the problems continued.  It would be up for a few hours, then down for the better part of the next day.  Posts wouldn’t save, pictures could not be loaded or plug-ins couldn’t be updated.  I have a service called ‘Jetpack’ that does a lot of the things that WordPress.com does for its customers, and since I use WordPress.ORG, I need that plug-in.  Which I have to pay for, but that’s another issue.  Inexplicably, that would disappear from my Journey blog, but the underlying files would still be on the website, so re-installing it wouldn’t work.

Finally, three weeks in, I wrote.  Squeaky wheel and all that.  Someone responded and said they’d look into the problem.  Fair enough, they apparently did and the sites started working again.  For a few hours, and then they disappeared.  Server errors galore, and the sites were unavailable for hours, if not days at a time.  Up and down, wash, rinse and repeat.  Every time I went to the hosting website, I could watch my bandwidth dwindle from 9 gigs/month to less than 1.  Traffic lost doesn’t necessarily come back.  Anyone that clicks on a link doesn’t want to wait 3-4 minutes for it to load, if at all.  They go somewhere else that’s more reliable.  That’s business 101 in a nutshell.

Yesterday, enough was enough.  I upped the volume a LOT.  I sent Servage an email and gave them a thinly veiled ultimatum, without actually saying that I was thinking of moving my circus elsewhere.  I did state quite unequivocally that I was a long-term customer, that I have been satisfied with the service I’ve received over the years, but the last two months have been incredibly difficult and I was as tired of writing them about my problem as I expect their admins were tired of hearing about it.  I received a message from one of the tech support people who said basically the admins were aware of the problem, they were working on it, and to check back in a few hours to see if things were better.  I had errands to run, but when I returned last evening, voila!  The sites loaded immediately.  At most, 10-15 seconds of wait time, not 3-4 minutes like it had been.  That’s an amazing change, and I was very grateful.  Though I wasn’t completely convinced.  I emailed them back, telling them it was working on my end, though I was leaving the support ticket open, just in case this was a momentary ‘hooray!’ moment, like all the other ones have been.

It’s been working fine for the better part of the last day.  They emailed me again to check on my experience and notify me that they were closing the support ticket on their end as they believed it was solved.  Leaving an open support ticket causes the admins to check periodically to be sure things are, or are not still ok.  It’s one less step they need to be doing.  Fair enough.  I’m hoping that things continue to work as they have been rather than what it has been.

Your comment or viewpoint is always welcome.

This site uses Akismet to reduce spam. Learn how your comment data is processed.