Geeking out

When it comes to desktop computers for me, either it rains, or it pours.  Mine never seem to behave correctly for very long, and since I build my own systems, I’m always tinkering with it, and trying to either fix something or keep it from crashing completely.

For the last six months, my issue has been with the monitor.  Or the video card that came attached to the motherboard of the desktop.  I think it was more the video card since I was able to use the monitor attached to my laptop, via an HDMI cable for a period of about a year.  My original issue was the desktop was misbehaving, I would power it up, it would run for about 30 seconds, then shut off again.  I spent the better part of a few days troubleshooting it, then decided it wasn’t worth my time and energy and shelved it while I used the laptop as a workaround.  I bought a 4-bay HD enclosure to simulate the storage on the desktop and for a time it worked ok.  It wasn’t the best configuration, but it was doable, and I wasn’t having too many issues.  True the desktop was basically a doorstop under my computer desk for a year, but it was out of the way and wasn’t causing an issue.  Every few weeks, if I remembered, I’d power up the desktop, it would go through its 30 seconds routine and shut down again.  And life would continue on.

Until one day when I powered it up, it stayed on and went through its complete startup.  Even to the point of starting Windows and just sitting there, as if it managed to fix itself.  I was, rather surprised to say the least.  Tech doesn’t fix itself.  At least not in my universe.  Maybe where Skynet™ is the dominant lifeform.  Not here.  Or at least I hope not.  Regardless, I didn’t take it for granted, I sprung into action and backed up settings, grabbed copies of programs and information I hadn’t been able to access for months (except for the really important stuff that I was able to pull from hard drives that I just physically removed from the tower and accessed remotely) and tentatively disconnected the laptop from the monitor, etc, and used the desktop again.  All the while thinking that maybe it was time to go to Newegg.com or Tigerdirect.com and get a new barebones system to replace this one.

Except I didn’t necessarily want to make the expense and headache of setting up a new system.  Barebones builds don’t always go so easily.  I compare it to the Johnny Cash song ‘One Piece at a Time‘, since you’re marrying different components to one system, and they all have to work in concert with one another.  The selling company does most of the hard work for you, in that they crunch the numbers and decide which motherboard and chipset work together, and make suggestions if you want to up or downgrade, depending on your needs.  If you’re a gamer, you’re going to want a more powerful system (an overclocked chip more than likely, a beefier motherboard, power supply, and so on) much more so than someone that does a few things in a multi-tasking form.  In the intervening years, I’ve upgraded to a 64-bit system from the 32-bit I grew up with, being able to access more of the memory onboard of the computer, and things run faster with the advent of access to broadband Internet.  We’re not talking dial-up or even DSL anymore.  Although it’s not the ‘big-leagues’ either.

Getting back to the issue at hand though.  My monitor has been acting up for the better part of the last few months.  The display occasionally cuts out, then comes back with distorted colors, or it just blanks out completely.  At that point I have little recourse than to shut down the computer via the power button, something I don’t like to do, as the OS (Operating System) doesn’t have the ability to shut down things in sync, it’s more like using a big on/off button to turn off the power.  Everything shuts down at once and that’s not good for the system.  I’ve kicked around the idea that it might be the HDMI cable or the connection on the motherboard.  The MB is 8 years old now, it’s gone through thousands of power on cycles and it might be time to move on.  At this point, my interim solution has been to order a new video card.

I didn’t want to order something really fancy-schmancy, since this is an older computer.  I don’t need to run heavy-duty computer games, there are no 3D or 4K necessities or make the monitor do headstands or star jumps, it just needs to communicate accurately with the tower, and let me see what’s going on and manipulate, all the visual things one does with a computer.

That being said, I went with a $55 MSI GeForce GT 710 card.  It does have some gaming capability, but mostly I needed a durable card that could support HDMI and DVI connections (I rarely use VGA anymore) so in the future when I do break down and build a new system, the card can come along for the ride.

The day before yesterday after work I decided to install it.  I have a can of compressed air, so I used that as well to evict the dust-bunny colony that had taken up residence in the tower.  As it turns out I almost used up the entire can, there were so many inside.  It took a little doing to get the card installed, as I’ve never been very good with my cables inside a computer tower.  Cables going this way and that, not tied down or tied together, or tied much in any way, so airflow inside is predictably problematic.  With a bit of finagling though, I got it installed.  Buttoned up the tower, reconnected all the appropriate cables, hit the power button, and…nothing.  Oh no.  Did I accidentally screw up the tower?  Was there some static electricity discharge I was unaware of? (I didn’t wear my static strap, though I probably should have while working with the delicate electronics but invariably I almost always forget).  After about a minute of fumbling (and dropping the tower on my left pinky) I figured out while I was balancing on the power strip, I accidentally shut it off.  Duh.

Tried it again with the power on and voila!  Success!  The tower powered up went through its checks and the monitor came on without a whit of the previous problems.  Of course, the native resolution was off, but I think that was initially set very low in case someone has a smaller monitor.  It took only a moment or two to get it set appropriately and register the card with the home office.  It’s been working like a champ ever since and I have to admit the colors on the monitor haven’t been this crisp in ages.  Very pleased with my purchase and looking forward to seeing what this baby can do in the coming weeks, months, and years.

2 Replies to “Geeking out”

    1. So far. But there have been some hiccups along the way. I’m hoping it’s a motherboard issue and not the card itself.

Comments are closed.